PortChannel is used to combine multiple physical interfaces into a single logical interface, boosting the bandwidth of a point-to-point connection between two switches.
On the other hand, TrunkPort helps to convey traffic from different VLANs over one connection linking two switches.
In this post, I will show you how to configure PortChannel with Trunk. We will first configure the multiple interfaces that connect the two switches to a port channel. And then we will proceed to trunk this port channel into a trunk port.
Network Topology
The network topology we will be making use of in this post is shown below. As you can see, it consists of two switches connected with multiple physical interfaces. We will configure etherchannel so that these multiple physical interfaces will be joined into one logical interface.
Also, the network topology consists of two VLANs, VLAN 10 and VLAN 20, each existing on the two layer 2 switches. In this demonstration, we will configure a trunk link between the two switches so that the traffic from vlan 10 on switch0 can be forwarded to hosts on vlan 10 on switch1.
Related content;
- How to Configure LACP Etherchannel on Cisco Switch in Packet Tracer
- How to Configure Etherchannel on Cisco Router
- How to Configure Layer 3 Etherchannel On Packet Tracer
- How to Configure Etherchannel Load Balancing
How to Configure PortChannel With Trunklink
Here are steps to configure Portchannel with Trunk;
Step 1: Create the VLANs and Access port
Enter the following commands to create the VLAN 10 and VLAN 20 and access port on each of the two switches.
Switch0
SW0>enable
SW0#configure terminal
SW0(config)#vlan 10
SW0(config-vlan)#exit
SW0(config)#vlan 20
SW0(config-vlan)#exit
SW0(config)#interface range fa0/4-5
SW0(config-if-range)#switchport mode access
SW0(config-if-range)#switchport access vlan 10
SW0(config-if-range)#interface range fa0/6-7
SW0(config-if-range)#switchport mode access
SW0(config-if-range)#switchport access vlan 20
Switch1
SW1>enable
SW1#configure terminal
SW1(config)#vlan 10
SW1(config-vlan)#exit
SW1(config)#vlan 20
SW1(config-vlan)#exit
SW1(config)#interface range fa0/4-5
SW1(config-if-range)#switchport mode access
SW1(config-if-range)#switchport access vlan 10
SW1(config-if-range)#exit
SW1(config)#interface range fa0/6-7
SW1(config-if-range)#switchport mode access
SW1(config-if-range)#switchport access vlan 20
Step 2: Create the portchannel
Enter the following commands to create portchannel on each of the layer 2 switch
Switch0
SW0>enable
SW0#configure terminal
SW0(config)#interface range fa0/1-3
SW0(config-if-range)#channel-group 2 mode active
Switch1
SW1>enable
SW1#configure terminal
SW1(config)#interface range fa0/1-3
SW1(config-if-range)#channel-group 2 mode active
The above command creates a LACP port channel on each of the layer 2 switches with modes active. We could decide to set the mode to passive on one of the two switches, and the two switches will still peer to form an etherchannel.
Step 3: Create the Trunkport
Enter the following commands to configure a trunklink between the two switches
Switch0
SW0>enable
SW0#configure terminal
SW0(config)#interface Port-channel2
SW0(config-if)#switchport mode trunk
Switch1
SW1>enable
SW1#configure terminal
SW1(config)#interface Port-channel2
SW1(config-if)#switchport mode trunk
Step 4: Test Configuration
First, check whether all the link lights have turned green in the network topology.
Then enter the following show commands to configure that portchannel and trunkport were created on each of the switches.
SW0#show etherchannel summary
SW0#show interfaces trunk
Switch0
SW0#show etherchannel summary
Flags: D - down P - in port-channel
I - stand-alone s - suspended
H - Hot-standby (LACP only)
R - Layer3 S - Layer2
U - in use f - failed to allocate aggregator
u - unsuitable for bundling
w - waiting to be aggregated
d - default port
Number of channel-groups in use: 1
Number of aggregators: 1
Group Port-channel Protocol Ports
------+-------------+-----------+----------------------------------------------
2 Po2(SU) LACP Fa0/1(P) Fa0/2(P) Fa0/3(P)
SW0#show interfaces trunk
Port Mode Encapsulation Status Native vlan
Po2 on 802.1q trunking 1
Port Vlans allowed on trunk
Po2 1-1005
Port Vlans allowed and active in management domain
Po2 1,10,20
Port Vlans in spanning tree forwarding state and not pruned
Po2 1,10,20
Switch1
SW1#show etherchannel summary
Flags: D - down P - in port-channel
I - stand-alone s - suspended
H - Hot-standby (LACP only)
R - Layer3 S - Layer2
U - in use f - failed to allocate aggregator
u - unsuitable for bundling
w - waiting to be aggregated
d - default port
Number of channel-groups in use: 1
Number of aggregators: 1
Group Port-channel Protocol Ports
------+-------------+-----------+----------------------------------------------
2 Po2(SU) LACP Fa0/1(P) Fa0/2(P) Fa0/3(P)
SW1#show interfaces trunk
Port Mode Encapsulation Status Native vlan
Po2 on 802.1q trunking 1
Port Vlans allowed on trunk
Po2 1-1005
Port Vlans allowed and active in management domain
Po2 1,10,20
Port Vlans in spanning tree forwarding state and not pruned
Po2 1,10,20
As shown above, portchannel (p02) with flag (SU) was created on each of the two switches. The flag (SU) denotes that layer 2 etherchannel was created and that it is in use.
Related content;
- How to Configure LACP Etherchannel on Cisco Switch in Packet Tracer
- How to Configure Etherchannel on Cisco Router
- How to Configure Layer 3 Etherchannel On Packet Tracer
- How to Configure Etherchannel Load Balancing
I am a passionate Networking Associate specializing in Telecommunications.
With a degree in Electronic engineering, I possess a strong understanding of electronic systems and the intricacies of telecommunications networks. I gained practical experience and valuable insights working for a prominent telecommunications company.
Additionally, I hold certifications in networking, which have solidified my expertise in network architecture, protocols, and optimization.
Through my writing skills, I aim to provide accurate and valuable knowledge in the networking field.
Connect with me on social media using the links below for more insights.
You can contact me using [email protected] or connect with me using any of the social media account linked below