VTP (VLAN Trunking Protocol) is a Cisco proprietary protocol designed to simplify VLAN management in large networks. It allows VLAN configuration on a central server switch, known as the VTP server, which then distributes this information to other switches in the network, called VTP clients.
Instead of configuring VLANs manually on each switch in the network, VTP enables VLAN configuration centrally on the VTP server, reducing configuration overhead and potential errors.
While VTP can simplify VLAN management, it carries risks, particularly the potential for unintended network-wide VLAN changes. Connecting an older switch with a higher revision number to the network can cause all switches in the domain to synchronize with it, potentially disrupting network connectivity. Due to these risks, it’s recommended to exercise caution with VTP and consider alternative VLAN management methods, especially in environments where network stability is critical.
There are three versions of VTP: Version 1, Version 2, and Version 3. Most modern Cisco switches support all three versions, while older switches may only support Versions 1 and 2.
VTP Modes:
VTP operates in three modes: Server, Client, and Transparent.
- VTP Server: Servers can add, modify, and delete VLANs. They store the VLAN database in non-volatile RAM (NVRAM), ensuring persistence across reboots. Servers advertise the latest VLAN database on trunk interfaces, and clients synchronize their VLAN databases with the server.
- VTP Client: Clients cannot modify VLANs. They synchronize their VLAN database with the server and advertise their VLAN database to other clients over trunk ports.
- VTP Transparent Mode: Switches in transparent mode do not synchronize their VLAN database. They maintain an independent VLAN database in NVRAM and can add, modify, or delete VLANs locally. While transparent switches don’t advertise their VLAN database, they forward VTP advertisements over trunk ports if the domain matches.
In this post, I will show you how to Configure VTP in Cisco Switch in packet tracer using a sample network topology.
Network topology
The network topology we will be making use of in this post is shown below. As you can see, it consists of 5 switches. In this demonstration, we will configure the VTP server on Switch 1 and then configure every other switch as a VTP client.
Download the premade lab file or recreate the network topology shown below on your packet tracer software.
How to Configure VTP in Cisco Switch in packet tracer
Here are the steps to configure VTP on a Cisco Switch using the network topology shown above:
Step 1: Configure the Trunk port between switches
SW1(config)#interface range fa0/1-3
SW1(config-if-range)#switchport mode trunk
SW1(config-if-range)#exit
SW2(config)#interface fa0/1
SW2(config-if)#switchport mode trunk
SW2(config-if)#exit
SW3(config)#interface fa0/1
SW3(config-if)#switchport mode trunk
SW3(config-if)#no shut
SW3(config-if)#exit
SW4(config)#interface range fa0/1-2
SW4(config-if-range)#switchport mode trunk
SW4(config-if-range)#exit
SW5(config)#interface fa0/1
SW5(config-if)#switchport mode trunk
SW5(config-if)#exit
Step 2: Configure the VTP Server
As labeled in the network topology, Switch1 will be serving as the VTP server. The commands to do that is shown below.
SW1(config)#vtp mode server
SW1(config)#vtp domain cisco
SW1(config)#vtp password cisco123
Here’s a brief explanation of each command:
- SW1(config)#vtp mode server:
- This command configures the VTP mode of the switch to “server” mode. In server mode, the switch can add, modify, and delete VLANs, and it maintains and advertises its VLAN database to other switches in the same VTP domain.
- SW1(config)#vtp domain cisco:
- This command sets the VTP domain name to “cisco”. The VTP domain is a logical grouping of switches that share VLAN information. All switches within the same VTP domain synchronize their VLAN configurations.
- SW1(config)#vtp password cisco123:
- This command sets the VTP password to “cisco123”. The VTP password is used for authentication between switches in the same VTP domain. Only switches with the correct VTP password can participate in VTP operations within that domain
Step 3: Configure the VTP Client
As labeled in the network topology, SW2, SW2, SW3, SW4, and SW5 will be configured as VTP clients. The commands to do that are shown below:
SW2(config)#vtp mode client
SW2(config)#vtp domain cisco <-- Configure to match SW1.
SW2(config)#vtp password cisco123 <-- Configure to match SW1.
SW3(config)#vtp mode client
SW3(config)#vtp domain cisco <-- Configure to match SW1.
SW3(config)#vtp password cisco123 <-- Configure to match SW1.
.
SW4(config)#vtp mode client
SW4(config)#vtp domain cisco <-- Configure to match SW1.
SW4(config)#vtp password cisco123 <-- Configure to match SW1.
SW5(config)#vtp mode client
SW5(config)#vtp domain cisco <-- Configure to match SW1.
SW5(config)#vtp password cisco123 <-- Configure to match SW1.
Step 4: View the VTP configuration information
On Switch 1
SW1#show vtp status
VTP Version capable : 1 to 2
VTP version running : 1
VTP Domain Name : cisco
VTP Pruning Mode : Disabled
VTP Traps Generation : Disabled
Device ID : 00E0.F91E.8A00
Configuration last modified by 0.0.0.0 at 0-0-00 00:00:00
Local updater ID is 0.0.0.0 (no valid interface found)
Feature VLAN :
--------------
VTP Operating Mode : Server
Maximum VLANs supported locally : 255
Number of existing VLANs : 5
Configuration Revision : 0
MD5 digest : 0x3A 0x72 0xB9 0x27 0x39 0xD8 0x05 0xA3
0x98 0xE2 0x34 0x45 0x20 0x7E 0x8B 0xED
On SW2
SW2#show vtp status
VTP Version capable : 1 to 2
VTP version running : 1
VTP Domain Name : cisco
VTP Pruning Mode : Disabled
VTP Traps Generation : Disabled
Device ID : 0090.21EA.3A00
Configuration last modified by 0.0.0.0 at 0-0-00 00:00:00
Feature VLAN :
--------------
VTP Operating Mode : Client
Maximum VLANs supported locally : 255
Number of existing VLANs : 5
Configuration Revision : 0
MD5 digest : 0x3A 0x72 0xB9 0x27 0x39 0xD8 0x05 0xA3
0x98 0xE2 0x34 0x45 0x20 0x7E 0x8B 0xED
Do the same on SW3,SW4 and SW5
Step 5: Create VLANs on the VTP Server
SW1(config)#vlan 10
SW1(config-vlan)#name Sales
SW1(config-vlan)#exit
SW1(config)#vlan 20
SW1(config-vlan)#name Engineer
SW1(config-vlan)#exit
SW1(config)#vlan 30
SW1(config-vlan)#name Marketing
SW1(config-vlan)#exit
SW1(config)#vlan 40
SW1(config-vlan)#name HR
SW1(config-vlan)#exit
SW1(config)#vlan 50
SW1(config-vlan)#name Admin
SW1(config-vlan)#exit
Step 6: Verify that VLANs are automatically Created on the VTP Client
SW2#show vlan
VLAN Name Status Ports
---- -------------------------------- --------- -------------------------------
1 default active Fa0/2, Fa0/3, Fa0/4, Fa0/5
Fa0/6, Fa0/7, Fa0/8, Fa0/9
Fa0/10, Fa0/11, Fa0/12, Fa0/13
Fa0/14, Fa0/15, Fa0/16, Fa0/17
Fa0/18, Fa0/19, Fa0/20, Fa0/21
Fa0/22, Fa0/23, Fa0/24, Gig0/1
Gig0/2
10 Sales active
20 Engineer active
30 Marketing active
40 HR active
50 Admin active
1002 fddi-default active
1003 token-ring-default active
1004 fddinet-default active
1005 trnet-default active
VLAN Type SAID MTU Parent RingNo BridgeNo Stp BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
1 enet 100001 1500 - - - - - 0 0
10 enet 100010 1500 - - - - - 0 0
20 enet 100020 1500 - - - - - 0 0
30 enet 100030 1500 - - - - - 0 0
40 enet 100040 1500 - - - - - 0 0
50 enet 100050 1500 - - - - - 0 0
Do the same on SW3, SW4, and SW5
Step 7: Check the Configuration Revision Number on the VTP server
SW1#show vtp status
VTP Version capable : 1 to 2
VTP version running : 1
VTP Domain Name : cisco
VTP Pruning Mode : Disabled
VTP Traps Generation : Disabled
Device ID : 00E0.F91E.8A00
Configuration last modified by 0.0.0.0 at 3-1-93 00:29:24
Local updater ID is 0.0.0.0 (no valid interface found)
Feature VLAN :
--------------
VTP Operating Mode : Server
Maximum VLANs supported locally : 255
Number of existing VLANs : 10
Configuration Revision : 10
MD5 digest : 0xF2 0x33 0xDE 0x80 0x69 0x28 0x82 0xCA
0xF9 0x7A 0x5E 0x83 0x23 0x0E 0xE3 0xDC
SW1#
Step 8: Display the VTP statistics on each of the Switch
You can check the VTP status by entering the following commands on each of the swtichs.
SW1#show vtp counters
SW2#show vtp counters
SW3#show vtp counters
SW4#show vtp counters
SW5#show vtp counters
Download the premade lab solution and compare with what you have done.
I am a passionate Networking Associate specializing in Telecommunications.
With a degree in Electronic engineering, I possess a strong understanding of electronic systems and the intricacies of telecommunications networks. I gained practical experience and valuable insights working for a prominent telecommunications company.
Additionally, I hold certifications in networking, which have solidified my expertise in network architecture, protocols, and optimization.
Through my writing skills, I aim to provide accurate and valuable knowledge in the networking field.
Connect with me on social media using the links below for more insights.
You can contact me using [email protected] or connect with me using any of the social media account linked below