EIGRP is a dynamic routing protocol that combines the characteristics of both distance vector and link-state algorithms to discover routes and build routing tables. It is an advanced distance vector protocol that has link-state-like features. It is a Cisco proprietary protocol.
EIGRP is an internal gateway protocol, meaning it is designed to be used with a single autonomous system (AS). EIGRP uses an AS number to create a group of routers that can share routing information. You can choose any number from the range 1 to 65535 as an AS number. After selecting a number, you have to use the same number on all routers. If two routers belong to different AS, they will not share routing information.
As with all routing protocols, the goal of EIGRP is to learn the best route to any given subnet within a network. EIGRP uses bandwidth and delay to calculate its metric.
EIGRP is faster than RIP, supports more than 15 hop counts, and sends messages using the multicast address 224.0.0.10. One of the unique capabilities of EIGRP is that it performs unequal cost-load balancing.
Unlike OSPF, which builds routing tables by building connectivity maps, EIGRP sends link state updates from one router to another in order to build routing tables.
EIGRP has a three-step process.
- Becoming Neighbors: Two routers running EIGRP on the same link agree to form a neighborly relationship. Once EIGRP is enabled on a router, it will start looking for a potential neighbor by sending broadcast hello messages to the address 224.0.0.10. Hello messages are also used to maintain neighborly relationships with other routers. For two routers to become neighbors, they must have the same AS number.
- Exchange routing information: neighbors exchange their topology information. It uses the reliable transport protocol(RTP) to send an update-type message. RTP uses a sequence number to identify if the message has been received by the neighbor. EIGRP uses the diffusing update algorithm (DUAL) to handle all route computation and ensure no routing loops occur.
- Choose the best route: Each router chooses the best route to add to its routing table. Here, the router uses the metric calculation formula to determine the best route. The metrics calculation formula is a function of both bandwidth and delay.
Now that we have a good understanding of EIGRP, let’s move on to the EIGRP configuration on Cisco routers.
Network Topology
The network topology we will be making use of in this post is shown in the image below. As you can see, it comprises five routers. In this demonstration, we will configure EIGRP on each of the routers so that they will be able to share routing information with each other.
How To Configure EIGRP on a Cisco Router
Here are steps to configure EIGRP on Cisco router using the network topology given above;
Step 1: Assign IP address to the Interfaces of the Routers
The first step is to configure the interface of the routers used in the network. Here are commands to do that.
Router 1
R1(config)#interface ethernet0/0
R1(config-if)#ip address 10.10.10.1 255.255.255.252
R1(config-if)#no shutdown
R1(config-if)#exit
R1(config)#interface ethernet0/1
R1(config-if)#ip address 10.10.10.9 255.255.255.252
R1(config-if)#no shutdown
R1(config-if)#exit
R1(config)#interface loopback 0
R1(config-if)#ip address 172.29.16.1 255.255.255.0
R1(config-if)#no shutdown
R1(config-if)#exit
Router 2
R2(config)#interface ethernet0/0
R2(config-if)#ip address 10.10.10.2 255.255.255.252
R2(config-if)#no shutdown
R2(config-if)#exit
R2(config)#interface ethernet0/1
R2(config-if)#ip address 10.10.10.5 255.255.255.252
R2(config-if)#no shutdown
R2(config-if)#exit
R2(config)#interface loopback 0
R2(config-if)#ip address 10.129.1.1 255.255.255.0
R2(config-if)#no shutdown
R2(config-if)#exit
Router 3
R3(config)#interface ethernet0/0
R3(config-if)#ip address 10.10.10.18 255.255.255.252
R3(config-if)#no shutdown
R3(config-if)#exit
R3(config)#interface ethernet0/1
R3(config-if)#ip address 10.10.10.6 255.255.255.252
R3(config-if)#no shutdown
R3(config-if)#exit
R3(config)#interface loopback 0
R3(config-if)#ip address 192.168.2.1 255.255.255.0
R3(config-if)#no shutdown
R3(config-if)#exit
Router 4
R4(config)#interface ethernet0/1
R4(config-if)#ip address 10.10.10.10 255.255.255.252
R4(config-if)#no shutdown
R4(config-if)#exit
R4(config)#interface ethernet0/2
R4(config-if)#ip address 10.10.10.13 255.255.255.252
R4(config-if)#no shutdown
R4(config-if)#exit
Router 5
R5(config)#interface ethernet0/0
R5(config-if)#ip address 10.10.10.17 255.255.255.252
R5(config-if)#no shutdown
R5(config-if)#exit
R5(config)#interface ethernet0/2
R5(config-if)#ip address 10.10.10.14 255.255.255.252
R5(config-if)#no shutdown
R5(config-if)#exit
Step 2: Configure EIGRP on the routers
Router 1
R1(config)#router eigrp 100
R1(config-router)#network 10.10.10.0 0.0.0.3
R1(config-router)#network 10.10.10.8 0.0.0.3
R1(config-router)#network 172.29.16.0 0.0.0.255
R1(config-router)#no auto-summary
R1(config-router)#exit
Here is a brief explanation of the above commands;
router eigrp 100
: This command enters EIGRP configuration mode and specifies the Autonomous System (AS) number 100 for the EIGRP process on router R1.network 10.10.10.0 0.0.0.3
: This command tells EIGRP to include the network 10.10.10.0 with a wildcard mask of 0.0.0.3 in its routing updates. It signifies that the router will participate in EIGRP routing for this network.network 10.10.10.8 0.0.0.3
: Similar to the previous command, this instructs EIGRP to include the network 10.10.10.8 with a wildcard mask of 0.0.0.3 in its routing updates. It indicates another network for EIGRP routing participation.network 172.29.16.0 0.0.0.255
: This command adds the network 172.29.16.0 with a wildcard mask of 0.0.0.255 to the EIGRP routing process, allowing router R1 to advertise this network to its EIGRP neighbors.no auto-summary
: This command disables automatic summarization of routes at network boundaries within the EIGRP process. It ensures that EIGRP advertises specific subnetwork routes rather than summarizing them into larger networks.
Router 2
R2(config)#router eigrp 100
R2(config-router)#network 10.10.10.0 0.0.0.3
R2(config-router)#network 10.10.10.4 0.0.0.3
R2(config-router)#network 10.129.1.0 0.0.0.255
R2(config-router)#no auto-summary
R2(config-router)#exit
Router 3
R3(config)#router eigrp 100
R3(config-router)#network 10.10.10.4 0.0.0.3
R3(config-router)#network 10.10.10.16 0.0.0.3
R3(config-router)#network 192.168.2.0 <-- Major Network Address
R3(config-router)#no auto-summary
R3(config-router)#exit
Router 4
R4(config)#router eigrp 100
R4(config-router)#network 10.10.10.8 0.0.0.3
R4(config-router)#network 10.10.10.12 0.0.0.3
R4(config-router)#no auto-summary
R4(config-router)#exit
Router 5
R5(config)#router eigrp 100
R5(config-router)#network 10.10.10.12 0.0.0.3
R5(config-router)#network 10.10.10.16 0.0.0.3
R5(config-router)#no auto-summary
R5(config-router)#exit
Step 3: Confirm The configuration
On each of the routers in the network, you need to check the status of nearby routers and the route that each router has learned.
Run the following command each on R1, R2, R3, R4, and R5 to see neighbor status and the routing table.
R1#show ip eigrp neighbors
R2#show ip eigrp neighbors
R3#show ip eigrp neighbors
R4#show ip eigrp neighbors
R5#show ip eigrp neighbors
R1#show ip route
R2#show ip route
R3#show ip route
R4#show ip route
R5#show ip route
Related Content
How To Configure Dynamic Routing In Cisco Packet Tracer
Static Route Configuration in Cisco Router
How To Configure OSPF on Layer 3 Switch In Packet Tracer
How to Configure RIP on Layer 3 Switch in Packet Tracer
How To Configure EIGRP on a Layer 3 Switch in Packet Tracer
Reference: https://github.com/misterkrittin/CCNA-Labs
I am a passionate Networking Associate specializing in Telecommunications.
With a degree in Electronic engineering, I possess a strong understanding of electronic systems and the intricacies of telecommunications networks. I gained practical experience and valuable insights working for a prominent telecommunications company.
Additionally, I hold certifications in networking, which have solidified my expertise in network architecture, protocols, and optimization.
Through my writing skills, I aim to provide accurate and valuable knowledge in the networking field.
Connect with me on social media using the links below for more insights.
You can contact me using [email protected] or connect with me using any of the social media account linked below