In this lab, the objective is to configure the OSPF Multi-Area Network (depicted below) to enable route summarization.
An OSPF multi-area network is a network that consists of numerous routers (often hundreds or thousands) organized into different areas. OSPF is configured in each of these specific areas with a different Area number.
Typically, when a large network is configured with an OSPF single area, it results in an extensive Link State Database (LSDB), leading to excessive routing to each router. This slows the network and overloads the routers.
To address this issue, OSPF multi-area configuration is recommended for large networks with more than 50 routers.
Network Topology
The network topology for this lab is show n below. As you can see, it consists of 3 OSPF areas: Area 0 (back bone area), Area 1, and Area 2.
Lab Objectives
The objective of this lab is to make the following configurations:
- Configure the IP address for the interfaces of the routers.
- Configure Multi-Area OSPF on the network, observing how the network is divided into Area 0, Area 1, and Area 2.
- The OSPF Process ID should be 1.
- Use the necessary show commands to view the OSPF configuration details.
Lab Solution
The following commands are the configuration needed to complete on the lab above;
on R1,
=======================================
R1(config)#interface ethernet0/1
R1(config-if)#ip address 192.168.12.1 255.255.255.0
R1(config-if)#no shutdown
R1(config-if)#exit
R1(config)#interface ethernet0/2
R1(config-if)#ip address 192.168.13.1 255.255.255.0
R1(config-if)#no shutdown
R1(config-if)#exit
R1(config)#router ospf 1
R1(config-router)#router-id 1.1.1.1
R1(config-router)#network 192.168.12.0 0.0.0.255 area 0
R1(config-router)#network 192.168.13.0 0.0.0.255 area 1
R1(config-router)#exit
=======================================
on R2,
=======================================
R2(config)#interface ethernet0/1
R2(config-if)#ip address 192.168.12.2 255.255.255.0
R2(config-if)#no shutdown
R2(config-if)#exit
R2(config)#interface ethernet0/2
R2(config-if)#ip address 192.168.24.2 255.255.255.0
R2(config-if)#no shutdown
R2(config-if)#exit
R2(config)#router ospf 1
R2(config-router)#router-id 2.2.2.2
R2(config-router)#network 192.168.12.0 0.0.0.255 area 0
R2(config-router)#network 192.168.24.0 0.0.0.255 area 2
R2(config-router)#exit
=======================================
on R3,
=======================================
R3(config)#interface ethernet0/1
R3(config-if)#ip address 192.168.13.3 255.255.255.0
R3(config-if)#no shutdown
R3(config-if)#exit
R3(config)#interface loopback 0
R3(config-if)#ip address 3.3.3.3 255.255.255.0
R3(config-if)#no shutdown
R3(config-if)#exit
R3(config)#router ospf 1
R3(config-router)#router-id 3.3.3.3
R3(config-router)#network 192.168.13.0 0.0.0.255 area 1
R3(config-router)#network 3.3.3.0 0.0.0.255 area 1
R3(config-router)#exit
=======================================
on R4,
=======================================
R4(config)#interface ethernet0/1
R4(config-if)#ip address 192.168.24.4 255.255.255.0
R4(config-if)#no shutdown
R4(config-if)#exit
R4(config)#interface loopback 0
R4(config-if)#ip address 4.4.4.4 255.255.255.0
R4(config-if)#no shutdown
R4(config-if)#exit
R4(config)#router ospf 1
R4(config-router)#router-id 4.4.4.4
R4(config-router)#network 192.168.24.0 0.0.0.255 area 2
R4(config-router)#network 4.4.4.0 0.0.0.255 area 2
R4(config-router)#exit
=======================================
The command that displays information about OSPF.
=======================================
R1#show ip ospf neighbor <-- Displays detailed neighbor information.
R2#show ip ospf neighbor
R3#show ip ospf neighbor
R4#show ip ospf neighbor
R1#show ip protocols <-- Displays information about OSPF, including the RouterID.
R2#show ip protocols
R3#show ip protocols
R4#show ip protocols
R1#show ip route ospf <-- Displays OSPF routing information.
R2#show ip route ospf
R3#show ip route ospf
R4#show ip route ospf
R1#show ip ospf database <-- Displays detailed OSPF database information. R2#show ip ospf database R3#show ip ospf database R4#show ip ospf database ======================================= >>>>> Testing <<<<<
=======================================
R3#ping 4.4.4.4 source 3.3.3.3
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 4.4.4.4, timeout is 2 seconds:
Packet sent with a source address of 3.3.3.3
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms
R4#ping 3.3.3.3 source 4.4.4.4
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 3.3.3.3, timeout is 2 seconds:
Packet sent with a source address of 4.4.4.4
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/3 ms
=======================================
If you need any detail about the above lab, here is a separate post where we explained it in detail; How to Configure OSPF Multi-Area
Reference: https://github.com/misterkrittin/CCNA-Labs
I am a passionate Networking Associate specializing in Telecommunications.
With a degree in Electronic engineering, I possess a strong understanding of electronic systems and the intricacies of telecommunications networks. I gained practical experience and valuable insights working for a prominent telecommunications company.
Additionally, I hold certifications in networking, which have solidified my expertise in network architecture, protocols, and optimization.
Through my writing skills, I aim to provide accurate and valuable knowledge in the networking field.
Connect with me on social media using the links below for more insights.
You can contact me using [email protected] or connect with me using any of the social media account linked below