Routers, just like switches, have the capability to join multiple physical interfaces into a logical interface referred to as an EtherChannel.
While switches extend support for dynamic negotiation protocols such as LACP and PAgP, along with static EtherChannels, routers only support static EtherChannels.
In a previous post, we demonstrated how to configure EtherChannel on the Layer 3 switch. In today’s guide, I will show you how to configure EtherChannel on a Cisco router.
Network Topology
The network topology we will be making use of in this post is shown below. As you can see, it consists of two routers joined by two crossover cables. In this demonstration, we will be configuring port channels on each of the routers so that a logical interface will be created and used to forward traffic from one router to the other.
Related content;
- How to Configure PortChannel With Trunk In Cisco Packet Tracer
- How to Configure LACP Etherchannel on Cisco Switch in Packet Tracer
- How to Configure Layer 3 Etherchannel On Packet Tracer
How to Configure Etherchannel on Cisco Router
Here are steps to configure etherchannel on cisco router;
Step 1: Create the Portchannels
Enter the following command to create portchannel on each of the routers
Router1
R1>enable
R1#configure terminal
R1(config)#int port-channel 20
R1(config-if)#int range g0/0/0 -1
R1(config-if-range)#channel-group 20
R1(config-if-range)#no shutdown
The Command above creates “port-channel 20” and assign the two physical interfaces; g0/0/0 and g0/0/1 to the port channel
Router0
R0>enable
R0#configure terminal
R0(config)#int port-channel 2
R0(config-if)#int range g0/0/0 -1
R0(config-if-range)#channel-group 2
R0(config-if-range)#no shut
The command above creates; “port-channel 2” and assign the two physical interfaces; g0/0/0 and g0/0/1 to the port channel
Step 2: Assign IP address to the port channel
Enter the following command to assign IP address to the portchannels created on each of the routers;
Router1
R1(config-if-range)#int port-channel 20
R1(config-if)#ip address 10.0.0.2 255.255.255.252
R1(config-if)#no shut
Router0
R0(config)#in port-channel 2
R0(config-if)#ip address 10.0.0.1 255.255.255.252
R0(config-if)#no shut
Step 3: Very if portchannel is created
Enter the following command each on the router to verify that portchannel was created successfully
show interface port-channel[portchannel ID]
Router0
R0#show interface port-channel2
Port-channel2 is up, line protocol is up (connected)
Hardware is EtherChannel, address is 000d.bdbb.96a0 (bia 000d.bdbb.96a0)
Internet address is 10.0.0.1/30
MTU 1500 bytes, BW 2100000 Kbit, DLY 1000 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation ARPA, loopback not set
Keepalive set (10 sec)
Half-duplex, 2100Mb/s
input flow-control is off, output flow-control is off
Members in this channel: Gig0/0/0 ,Gig0/0/1 ,
ARP type: ARPA, ARP Timeout 04:00:00
Last input 00:00:08, output 00:00:05, output hang never
Last clearing of "show interface" counters never
Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
Queueing strategy: fifo
Output queue :0/40 (size/max)
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
956 packets input, 193351 bytes, 0 no buffer
Received 956 broadcasts, 0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
0 watchdog, 0 multicast, 0 pause input
0 input packets with dribble condition detected
2357 packets output, 263570 bytes, 0 underruns
0 output errors, 0 collisions, 10 interface resets
0 babbles, 0 late collision, 0 deferred
0 lost carrier, 0 no carrier
0 output buffer failures, 0 output buffers swapped out
Router1
R1#show interface port-channel20
Port-channel20 is up, line protocol is up (connected)
Hardware is EtherChannel, address is 0090.0cb2.9c04 (bia 0090.0cb2.9c04)
Internet address is 10.0.0.2/30
MTU 1500 bytes, BW 2100000 Kbit, DLY 1000 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation ARPA, loopback not set
Keepalive set (10 sec)
Half-duplex, 2100Mb/s
input flow-control is off, output flow-control is off
Members in this channel: Gig0/0/0 ,Gig0/0/1 ,
ARP type: ARPA, ARP Timeout 04:00:00
Last input 00:00:08, output 00:00:05, output hang never
Last clearing of "show interface" counters never
Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
Queueing strategy: fifo
Output queue :0/40 (size/max)
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
956 packets input, 193351 bytes, 0 no buffer
Received 956 broadcasts, 0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
0 watchdog, 0 multicast, 0 pause input
0 input packets with dribble condition detected
2357 packets output, 263570 bytes, 0 underruns
0 output errors, 0 collisions, 10 interface resets
0 babbles, 0 late collision, 0 deferred
0 lost carrier, 0 no carrier
0 output buffer failures, 0 output buffers swapped out
Alternatively, you can verify that the port channel was created by pinging the IP address assigned to the port channel from the other port channel interface.
Related content;
- How to Configure PortChannel With Trunk In Cisco Packet Tracer
- How to Configure LACP Etherchannel on Cisco Switch in Packet Tracer
- How to Configure Layer 3 Etherchannel On Packet Tracer
I am a passionate Networking Associate specializing in Telecommunications.
With a degree in Electronic engineering, I possess a strong understanding of electronic systems and the intricacies of telecommunications networks. I gained practical experience and valuable insights working for a prominent telecommunications company.
Additionally, I hold certifications in networking, which have solidified my expertise in network architecture, protocols, and optimization.
Through my writing skills, I aim to provide accurate and valuable knowledge in the networking field.
Connect with me on social media using the links below for more insights.
You can contact me using [email protected] or connect with me using any of the social media account linked below