How To Configure EIGRP on a Layer 3 Switch in Packet Tracer

Layer 3 switches, commonly known as multilayer switches, possess the capability to perform both routing and switching functions. While these switches can inherently handle switching, we need to enable IP routing on their interface for them to be able to handle packet routing.

In this post, I will show you how to configure EIGRP on a Layer 3 switch in Packet Tracer. EIGRP is a dynamic routing protocol that combines the characteristics of both distance vector and link-state algorithms to discover routes and build the routing table. After EIGRP configuration on layer 3 switch, hosts existing on one subnetwork will be able to communicate with hosts existing on the other subnetwork.

Network Topology

The network topology that we will be using in this post is as shown in the image below. As you can see, it consists of two-layer switches with three PCs connected to each of them.

network topology comprising of 2 layer 3 switches and 6 PCs

 

How To Configure EIGRP on a Layer 3 Switch

Configuring EIGRP on a multilayer switch is similar to EIGRP configuration on a router, except that you need to enable IP routing on the Multilayer switch and also turn the switchports into routed ports.

ALSO READ:  How to Configure Layer 3 Switch in Packet Tracer | Inter-Vlan Routing with Layer 3 Switch

Here is a step-by-step guide on how to configure EIGRP on a layer switch:

Step 1: Assign IP addresses to Switch interfaces

Here, we will need to assign an IP address to the switch virtual interfaces (SVI) and also to the physical interfaces the switch is using to connect to each other.

The IP address assigned to the SVI is utilized as the default gateway for all the host devices existing on such a subnetwork.

The IP address assigned to the switch physical interfaces (fa0/1) will be utilized to identify each switch on the network. Before assigning an IP address to the fa0/1 interface on each switch, we need to turn it into a routed port.

Here are commands to assign IP address to the switch interfaces;

Multilayer Switch0

Switch>en
Switch#conf t
Switch(config)#hostname SW0
SW0(config)#int vlan1
SW0(config-if)#ip address 192.168.3.1 255.255.255.0
SW0(config-if)#no shut
SW0(config-if)#exit
SW0(config)#ip routing
SW0(config)#int fa0/1
SW0(config-if)#no switchport
SW0(config-if)#ip address 192.168.2.1 255.255.255.0
SW0(config-if)#no shut

Multilayer Switch1

Switch#en
Switch#conf t
Switch(config)#hostname SW1
SW1(config)#int Vlan1  
SW1(config-if)#ip address 192.168.1.1 255.255.255.0
SW1(config-if)#no shut
SW1(config-if)#exit
SW1(config)#ip routing 
SW1(config)#int fa0/1
SW1(config-if)#no switchport
SW1(config-if)#ip address 192.168.2.2 255.255.255.0
SW1(config-if)#no shut

Step 2: Configure EIGRP

Configuring EIGRP involves specifying the autonomous system number (AS number), which should be consistent among EIGRP neighbors. Followed by this, the ‘network’ command is utilized to advertise the networks present on the interfaces of the Layer 3 switch.

Additionally, it is recommended to disable auto-summarization for more granular control over route advertisements. This ensures proper alignment and synchronization within the EIGRP domain.

Multilayer Switch1

Enter the following command to configure EIGRP on SW1:

SW1>en
SW1#conf t
SW1(config)#router eigrp 100
SW1(config-router)#network 192.168.1.0
SW1(config-router)#network 192.168.2.0
SW1(config-router)#no auto-summary

Multilayer Switch0

Enter the following command to configure a EIGRP on SW0:

SW0>en
SW0#conf t
SW0(config)#router eigrp 100
SW0(config-router)#network 192.168.3.0
SW0(config-router)#network 192.168.2.0
SW0(config-router)#no auto-summary

EIGRP can be confirmed as shown in the image below;

Image showing EIGRP route

 

Step 3: Verify connectivity.

Open the command prompt on PC0 and ping the IP address of PC4 to verify connectivity. As shown in the image below, we got a reply.

An image showing ping reply from PC 4

Related Post

Leave a Comment

Your email address will not be published. Required fields are marked *

Scroll to Top