Connecting and configuring three routers in Packet Tracer can be a complex task, especially if you are not familiar with static route configuration. Additionally, when attempting to connect more than two devices to router, such as switches and/or other routers, you may encounter challenges because routers typically have two interfaces (g0/0 and g0/1) available for connections to other routers or switches. This can be mitigated by connecting the routers using serial ports.
In this post, I will demonstrate how to configure 3 routers and ensure that host devices on any side of the network can communicate effectively.
To enable communication between host devices located on one side of a router and those on the other side of a neighboring router, it is essential to configure static routes in each router to establish routing tables for each network address.
In this article, I will show you how to configure 3 routers using both the Graphical User Interface (GUI) and the Command Line Interface (CLI)
Here is a video tutorial on to configure 3 routers in packet tracer;
Network Topology
The network topology we will be making use of in this post is as shown below. As you can see, it consists of 3 routers, 3 switches each connected to the router, and 2 PCs connected to each of the switches.
To create this network topology, add the three routers, three switches, and six PCs to the packet tracer. Follow this guide to join the routers with a serial cable. Or watch the video below;
Then, join the switches to the routers and the PCs to the switches with copper straight-through cables.
How to Configure 3 Routers Using GUI
For newbie networking students, configuring using the graphic user interface (GUI) is much easier, even though it offers fewer functionalities than configuring with the command-line interface. However, we can achieve our configuration objective for this post using the GUI.
Here are the steps to configure 3 routers using GUI;
Step 1: Assign IP addresses to the routers interfaces
First Router
Select Router 5 to access the configuration options. Then Click on the “Config” tab and select the “serial0/1/0” interface.
Assign the IP address; 192.168.2.1 to this interface (s0/1/0) and the subnet mask of 255.255.255.0, and then turn on the port status.
Navigate to the g0/0/0 interface and assign Ip address; 192.168.5.1 to it.
Second Router
Follow the same steps we took in configuring router 5 above to configure s0/1/0 interface, s0/1/1 interface and g0/0/0 interface of Router 4(Let me know in the comment section if encounter any difficulty). The Ip address for s0/1/0 interface is 192.168.1.1, that of s0/1/1 is 192.168.2.2 and that of g0/0/0 interface is 192.168.4.1
Third Router
Follow the same steps we took in configuring router 5 above to configure s0/1/0 interface and g0/0/0 interface of router3. The Ip address of so/1/0 should be 192.168.1.2 and that of g0/0/0 interface should be 192.168.3.1.
Step 2: Assign IP addresses to the PCs.
Select each of the PCs to access the GUI and assign IP address as labelled in the network topology above. The video below demonstrates how to assign IP address to a PCs
Note: The default gateway IP address is the IP address of the router that the PC is connected to.
Step 3: Configure next hop & Network address Using GUI
Every router in a network has a routing table that it uses to forward data packets to their destination. Routing tables can be built dynamically or configured manually by network engineers.
Here are the steps to configure the routing table for the two routers in Cisco Packet Tracer using the GUI:
First router (Router 5)
- Tap on Router 5.
- Navigate to the “Config” tab and select “Routing” (refer to the image below).
- Navigate to the “Static” tab to configure the network address and Next Hop address.
Network address is the address of the network you are trying to add to the routing table of router 5 (192.168.1.0), and next of hop is the IP address of the interface of the next router, which is closer to the destination network.
Also, configure static route to the network; 192.168.4.0/24, and the network 192.168.3.0/24 on router 5
Second Router (Router 4)
Follow the steps outlined above to configure static route to the network; 192.168.5.0/24 on router 4.
Also, configure the static route to the network 192.168.3.0/24 on router 4;
Third Router (Router 3)
Follow the steps above to configure static route to the network; 192.168.4.0/24, 192.168.5.0/24 and 192.168.2.0/24 on router 3;
Step 4: Verify the connectivity
Open the command prompt on PC 2 and ping the IP address of PC 7 to check connectivity. If you configure it properly, you should receive a reply.
How to Configure 3 Routers Using CLI
Configuring three routers using the Command Line Interface (CLI) provides a faster and more precise method for experienced users. In this section, we will outline the steps and commands to assign IP addresses to router interfaces and configure static routes.
Step 1: Assign IP addresses to router interfaces
First Router (Router 5)
- Access the CLI of Router 5.
- Configure the IP address for the
s0/1/0
interface:
Router(config)#interface s0/1/0
Router(config-if)#ip address 192.168.2.1 255.255.255.0
Router(config-if)#no shutdown
3. Assign an IP address to the g0/0/0
interface:
Router(config-if)#interface g0/0/0
Router(config-if)#ip address 192.168.5.1 255.255.255.0
Router(config-if)#no shutdown
Second Router (Router 4)
- Access the CLI of Router 4.
- Configure the
s0/1/0
,s0/1/1
, andg0/0/0
interfaces as follows:
Router>enable
Router#configure terminal
Router(config)#interface s0/1/0
Router(config-if)#ip address 192.168.1.1 255.255.255.0
Router(config-if)#no shutdown
Router(config-if)#interface s0/1/1
Router(config-if)#ip address 192.168.2.2 255.255.255.0
Router(config-if)#no shutdown
Router(config-if)#interface g0/0/0
Router(config-if)#ip address 192.168.4.1 255.255.255.0
Router(config-if)#no shutdown
Third Router (Router 3)
- Access the CLI of Router 3.
- Configure the
s0/1/0
andg0/0/0
interfaces as follows:
Router#conf t
Router(config)#interface s0/1/0
Router(config-if)#ip address 192.168.1.2 255.255.255.0
Router(config-if)#no shutdown
Router(config-if)#interface g0/0/0
Router(config-if)#ip address 192.168.3.1 255.255.255.0
Router(config-if)#no shutdown
Router(config-if)#exit
Step 2: Configure Static Routes
First Router (Router 5)
- Access the CLI of Router 5.
- Configure static routes to the networks:
Router#conf t
Router(config-if)#ip route 192.168.4.0 255.255.255.0 192.168.2.2
Router(config)#ip route 192.168.3.0 255.255.255.0 192.168.1.1
Second Router (Router 4)
- Access the CLI of Router 4.
- Configure static routes to the networks:
Router#conf t
Router(config)#ip route 192.168.5.0 255.255.255.0 192.168.2.1
Router(config)#ip route 192.168.3.0 255.255.255.0 192.168.1.2
Third Router (Router 3)
- Access the CLI of Router 3.
- Configure static routes to the networks:
Router#conf t
Router(config)#ip route 192.168.4.0 255.255.255.0 192.168.1.1
Router(config)#ip route 192.168.5.0 255.255.255.0 192.168.2.2
Router(config)#ip route 192.168.2.0 255.255.255.0 192.168.1.1
Step 3: Verify Connectivity
- Open the command prompt on one of the PCs (e.g., PC 7).
- Ping the IP address of another PC (e.g., PC 2) to verify connectivity.
I am a passionate Networking Associate specializing in Telecommunications.
With a degree in Electronic engineering, I possess a strong understanding of electronic systems and the intricacies of telecommunications networks. I gained practical experience and valuable insights working for a prominent telecommunications company.
Additionally, I hold certifications in networking, which have solidified my expertise in network architecture, protocols, and optimization.
Through my writing skills, I aim to provide accurate and valuable knowledge in the networking field.
Connect with me on social media using the links below for more insights.
You can contact me using [email protected] or connect with me using any of the social media account linked below