In this lab, the objective is to configure the Enhanced Interior Gateway Routing Protocol (EIGRP) on a network consisting of five Cisco routers (R1, R2, R3, R4, and R5). EIGRP is a dynamic routing protocol that enables routers to share routing information and automatically adjust to changes in the network topology.
Network Topology
The network topology of this lab is shown below. As you can see, it comprises five routers connected together.
EIGRP Lab Objectives
- Configure IP addresses on router interfaces to establish connectivity within the network.
- Enable EIGRP routing protocol on each router to facilitate dynamic routing.
- Advertise network subnets using EIGRP to allow routers to learn about available paths.
- Verify EIGRP neighbor adjacencies and routing table entries to ensure proper operation of the routing protocol.
EIGRP Lab Solution
The following commands are the configuraiton needed to complete on the lab above;
on R1,
=========================================
R1(config)#interface ethernet0/0
R1(config-if)#ip address 10.10.10.1 255.255.255.252
R1(config-if)#no shutdown
R1(config-if)#exit
R1(config)#interface ethernet0/1
R1(config-if)#ip address 10.10.10.9 255.255.255.252
R1(config-if)#no shutdown
R1(config-if)#exit
R1(config)#interface loopback 0
R1(config-if)#ip address 172.29.16.1 255.255.255.0
R1(config-if)#no shutdown
R1(config-if)#exit
R1(config)#router eigrp 100
R1(config-router)#network 10.10.10.0 0.0.0.3
R1(config-router)#network 10.10.10.8 0.0.0.3
R1(config-router)#network 172.29.16.0 0.0.0.255
R1(config-router)#no auto-summary
R1(config-router)#exit
=========================================
on R2,
=========================================
R2(config)#interface ethernet0/0
R2(config-if)#ip address 10.10.10.2 255.255.255.252
R2(config-if)#no shutdown
R2(config-if)#exit
R2(config)#interface ethernet0/1
R2(config-if)#ip address 10.10.10.5 255.255.255.252
R2(config-if)#no shutdown
R2(config-if)#exit
R2(config)#interface loopback 0
R2(config-if)#ip address 10.129.1.1 255.255.255.0
R2(config-if)#no shutdown
R2(config-if)#exit
R2(config)#router eigrp 100
R2(config-router)#network 10.10.10.0 0.0.0.3
R2(config-router)#network 10.10.10.4 0.0.0.3
R2(config-router)#network 10.129.1.0 0.0.0.255
R2(config-router)#no auto-summary
R2(config-router)#exit
=========================================
on R3,
=========================================
R3(config)#interface ethernet0/0
R3(config-if)#ip address 10.10.10.18 255.255.255.252
R3(config-if)#no shutdown
R3(config-if)#exit
R3(config)#interface ethernet0/1
R3(config-if)#ip address 10.10.10.6 255.255.255.252
R3(config-if)#no shutdown
R3(config-if)#exit
R3(config)#interface loopback 0
R3(config-if)#ip address 192.168.2.1 255.255.255.0
R3(config-if)#no shutdown
R3(config-if)#exit
R3(config)#router eigrp 100
R3(config-router)#network 10.10.10.4 0.0.0.3
R3(config-router)#network 10.10.10.16 0.0.0.3
R3(config-router)#network 192.168.2.0 <-- Major Network Address
R3(config-router)#no auto-summary
R3(config-router)#exit
=========================================
on R4,
=========================================
R4(config)#interface ethernet0/1
R4(config-if)#ip address 10.10.10.10 255.255.255.252
R4(config-if)#no shutdown
R4(config-if)#exit
R4(config)#interface ethernet0/2
R4(config-if)#ip address 10.10.10.13 255.255.255.252
R4(config-if)#no shutdown
R4(config-if)#exit
R4(config)#router eigrp 100
R4(config-router)#network 10.10.10.8 0.0.0.3
R4(config-router)#network 10.10.10.12 0.0.0.3
R4(config-router)#no auto-summary
R4(config-router)#exit
=========================================
on R5,
=========================================
R5(config)#interface ethernet0/0
R5(config-if)#ip address 10.10.10.17 255.255.255.252
R5(config-if)#no shutdown
R5(config-if)#exit
R5(config)#interface ethernet0/2
R5(config-if)#ip address 10.10.10.14 255.255.255.252
R5(config-if)#no shutdown
R5(config-if)#exit
R5(config)#router eigrp 100
R5(config-router)#network 10.10.10.12 0.0.0.3
R5(config-router)#network 10.10.10.16 0.0.0.3
R5(config-router)#no auto-summary
R5(config-router)#exit
=========================================
on R1,R2,R3,R4 and R5
=========================================
R1#show ip eigrp neighbors
R2#show ip eigrp neighbors
R3#show ip eigrp neighbors
R4#show ip eigrp neighbors
R5#show ip eigrp neighbors
R1#show ip route
R2#show ip route
R3#show ip route
R4#show ip route
R5#show ip route
or
R1#show ip route eigrp
R2#show ip route eigrp
R3#show ip route eigrp
R4#show ip route eigrp
R5#show ip route eigrp
=========================================
If you need any detail about the above lab, here is a separate post where we explained it in detail; How To Configure EIGRP on a Cisco Router
Reference: https://github.com/misterkrittin/CCNA-Labs
I am a passionate Networking Associate specializing in Telecommunications.
With a degree in Electronic engineering, I possess a strong understanding of electronic systems and the intricacies of telecommunications networks. I gained practical experience and valuable insights working for a prominent telecommunications company.
Additionally, I hold certifications in networking, which have solidified my expertise in network architecture, protocols, and optimization.
Through my writing skills, I aim to provide accurate and valuable knowledge in the networking field.
Connect with me on social media using the links below for more insights.
You can contact me using [email protected] or connect with me using any of the social media account linked below